The stage resolution is tied to its MUGEN version compatibility, if detected as "MUGEN 1.0+" then the stage requires MUGEN 1.0 or higher.